Sie sind hier

BerkeleyDB needs compatible versions of libdb & db.h you have db.h version 5.1.25 and libdb version 5.1.29 then a bunch of error

4 posts / 0 new
Letzter Beitrag
stratfordv
Bild des Benutzers stratfordv
BerkeleyDB needs compatible versions of libdb & db.h you have db.h version 5.1.25 and libdb version 5.1.29 then a bunch of error

Linux NIXLAP 3.8.0-23-generic #34-Ubuntu SMP Wed May 29 20:22:58 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

LinuxMint 15

Error report when installing.

Starting opsview-web:
BerkeleyDB needs compatible versions of libdb & db.h
    you have db.h version 5.1.25 and libdb version 5.1.29
Compilation failed in require at /usr/local/nagios/perl/lib/Cache/BerkeleyDB_Backend.pm line 7.
BEGIN failed--compilation aborted at /usr/local/nagios/perl/lib/Cache/BerkeleyDB_Backend.pm line 7.
Compilation failed in require at /usr/local/nagios/perl/lib/Cache/BerkeleyDB.pm line 10.
BEGIN failed--compilation aborted at /usr/local/nagios/perl/lib/Cache/BerkeleyDB.pm line 10.
Compilation failed in require at /usr/local/nagios/perl/lib/Catalyst/Plugin/Cache/BerkeleyDB.pm line 4.
BEGIN failed--compilation aborted at /usr/local/nagios/perl/lib/Catalyst/Plugin/Cache/BerkeleyDB.pm line 4.
Compilation failed in require at /usr/local/nagios/perl/lib/Class/Load.pm line 177.
Compilation failed in require at /usr/local/nagios/perl/lib/Catalyst/ScriptRunner.pm line 50.
...done
invoke-rc.d: initscript opsview-web, action "start" failed.
dpkg: error processing opsview-web (--configure):
 subprocess installed post-installation script returned error exit status 255
dpkg: dependency problems prevent configuration of opsview:
 opsview depends on opsview-web (>= 3.20130522.0.12328); however:
  Package opsview-web is not configured yet.

dpkg: error processing opsview (--configure):
 dependency problems - leaving unconfigured
Processing triggers for ureadahead ...
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 opsview-web
 opsview
E: Sub-process /usr/bin/dpkg returned an error code (1)

 

Any help would be greatly appreciated.  Really looking forward to getting this running.

 

Thanks

 

smarsh
Bild des Benutzers smarsh
Re: BerkeleyDB needs compatible versions of libdb & db.h you ...

Hello,

Can you ensure you are trying to install this on a supported platform: 

http://docs.opsview.com/doku.php?id=opsview-core:platforms

Best,

Sam

stratfordv
Bild des Benutzers stratfordv
Re: BerkeleyDB needs compatible versions of libdb & db.h you ...

Darn,  Thought you would support newer releases, just not older.  Will this run in a VM as I can't very well take my system back to the older version.  But I really do appreciate the quick response!!!

Just some other noteworthy info

Distributor ID:    LinuxMint
Description:    Linux Mint 15 Olivia
Release:    15
Codename:    olivia

Package: opsview-perl
Status: install ok installed
Priority: optional
Section: misc
Installed-Size: 117901
Maintainer: Opsview Support <support@opsview.com>
Architecture: amd64
Version: 4.4.0.779-1precise1
Depends: libc6 (>= 2.15), libdb5.1, libexpat1 (>= 1.95.8), libgcc1 (>= 1:4.1.1), libgif4 (>= 4.1.4), libjpeg8 (>= 8c), libmysqlclient18 (>= 5.5.13-1), libperl5.14 (>= 5.14.2), libpng12-0 (>= 1.2.13-4), libssl1.0.0 (>= 1.0.1), libstdc++6 (>= 4.1.1), libuuid1 (>= 2.16), libxml2 (>= 2.7.4), perl, libnet-dns-perl, librrds-perl (>= 1.2), libnet-snmp-perl, libsnmp-perl, libxml-perl, libdbd-mysql-perl, libdbi-perl, libnet-daemon-perl, libwww-perl, libarchive-zip-perl
Description: Perl modules for Opsview
 Provides the pre-requisite perl modules for Opsview, a
 network monitoring system based on Nagios.
Homepage: http://www.opsview.com/

opsview-perl: /opt/opsview/perl/lib/perl5/Tree/Simple/Visitor/VariableDepthClone.pm
opsview-perl: /opt/opsview/perl/lib/perl5/x86_64-linux-gnu-thread-multi/Clone.pm
libclone-perl: /usr/lib/perl5/Clone.pm

smarsh
Bild des Benutzers smarsh
Re: BerkeleyDB needs compatible versions of libdb & db.h you ...

Hi,

Yep - we have pre-configured virtual appliances available via the download sections. It wont run on Linux Mint, regardless of version - as its really a desktop OS.

Best,

Sam