You are here

Opsview Pro 4.4 AWS support Ruby plugin not working

4 posts / 0 new
Last post
onebox
onebox's picture
Opsview Pro 4.4 AWS support Ruby plugin not working

Hello,

I have an opsview pro instance updated to version 4.4. I'm trying to use the new templates for service checks uing Cloudwath but I'm having some trouble.

Every time I try one of those cheks I get this error:

This plugin, used by Amazon Cloudwatch, requires rubygems and the CloudyScripts gem to be installed
Please ensure rubygems is installed, then run 'gem install CloudyScripts' to use this plugin

If I do 'gem list --local' this is what I get:

amazon-ec2 (0.9.17)
CloudyScripts (2.14.64)
net-scp (1.1.2)
net-sftp (2.1.2)
net-ssh (2.6.8)
xml-simple (1.1.2)
zip (2.0.2)
 

So, rubygems and CloudyScripts it's installed but it doesn't work. Any advice? Thanks!

smarsh
smarsh's picture
Re: Opsview Pro 4.4 AWS support Ruby plugin not working

Hello,

Please contact Opsview support via http://support.opsview.com - they will be the best ones to help you.

Best,

Sam

onebox
onebox's picture
Re: Opsview Pro 4.4 AWS support Ruby plugin not working

Will contact support then, thanks :)

rabahc
rabahc's picture
Re: Opsview Pro 4.4 AWS support Ruby plugin not working

Hi All,

 

I have the same issue with opsview core free , I am tring to install the cloudwatch plugin and followed the instructions given on doc : http://docs.opsview.org/doku.php?id=opsview4.5:opspacks:templates:amazon...

 

when I try the command :

sudo ruby /usr/local/nagios/libexec/plugins.d/cloud-aws/encrypt_aws_credentials.rb -A (Amazon Access ID) -S (Amazon Secret Key) -f /usr/local/nagios/etc/aws_credentials.cfg

I get this error :

ruby: No such file or directory --/usr/local/nagios/libexec/plugins.d/cloud-aws/encrypt_aws_credentials.rb (LoadError)

When I checked on /usr/local/nagios/libexec/plugins.d there is no cloud-aws directory ? should I install the plugin

amazoncloudwatch , I tried to find the plugin on web but there is no Link.

gem list --local

*** LOCAL GEMS ***

amazon-ec2 (0.9.17)
CloudyScripts (2.14.64, 1.5.19)
net-scp (1.1.2)
net-sftp (2.1.2)
net-ssh (2.7.0)
xml-simple (1.1.3)
zip (2.0.2)
 

Any Idea ?