You are here

OPSVIEW ORA-12504: TNS:listener

7 posts / 0 new
Last post
IT_19
IT_19's picture
OPSVIEW ORA-12504: TNS:listener

Hi,

I'm trying to configure one of the hosts to be monitored with the oracle template and followed the instructions here:-

http://docs.opsview.com/doku.php?id=opsview4.6:opspacks:templates:oracle...

Tested connecting manually to the host database using sqlplus

But now all the checks are given the following error:-

CRITICAL - cannot connect to host.mydomain. ORA-12504: TNS:listener was not given the SERVICE_NAME in CONNECT_DATA (DBD ERROR: OCIServerAttach)

Thanks,

 

 

adamjwsuch_86531
adamjwsuch_86531's picture
Plugin attributes

Hi IT_19,

There are a number of attributes embedded in these Oracle service checks, these will look like "%ORACREDENTIALS:1%".

Have you completed all of the attributes for the checks you have added in? You can find more information on attributes here:

http://docs.opsview.com/doku.php?id=opsview4.6:attribute

 

 

IT_19
IT_19's picture
Hello,

Hello,

I provided the crendetials attribute and also tested the following command using the user "nagios"

sqlplus 'sys/******@(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(Host=HOSTNAME)(Port=1521))(CONNECT_DATA=(SID=VALUE)))'

The problem is regarding the "Services_Name", i tried to find its attribute in the oracle services check but could not.

Thanks,

 

adamjwsuch_86531
adamjwsuch_86531's picture
Hello,

Hello,

Is there a perticular service check within this host template you are having trouble with? 

Where have you found  "Services_Name", this does not appear to be part of the plugin.

Thanks

 

IT_19
IT_19's picture
Hello,

Hello,

 

The below error appeared as a result of all the service checks:-

 

CRITICAL - cannot connect to host.mydomain. ORA-12504: TNS:listener was not given the SERVICE_NAME in CONNECT_DATA (DBD ERROR: OCIServerAttach)

 

 

adamjwsuch_86531
adamjwsuch_86531's picture
This looks like a database

This looks like a database authentication issue. The easiest way to debug this would be to ensure you can get a sqlplus connection remotely before attempting to use the plugin.

A quick google throws up quite a few forums where people are having the same issue with remote connections. 

IT_19
IT_19's picture
Hello,

Hello,

I confirmed on my reply on Tue, 06/02/2015 - 09:22 that i used the credentials and connected successfully to the database remotley, check below.