You are here

LDAP Authentication Issue

1 post / 0 new
jblows
jblows's picture
LDAP Authentication Issue

Hi,

I'm having an issue with LDAP authentication with OpsView Core (version 3.20131016.0)

Having set up the opsview_web_local.yml file with the relevant details for our Active Directory I created the xml file referencing the AD group (Opsview_Admin) and ran the opsview_sync_ldap -t. It output an error when a binddn and bindpwd were entered, however worked when both fields were removed.

On running /usr/local/nagios/bin/opsview_sync_ldap

The output was the following:

Class::C3::Componentised::load_components(): Use of DBIx::Class::UTF8Columns is strongly discouraged. See documentation of DBIx::Class::UTF8Columns for more info
Use of uninitialized value $binddn in string eq at /usr/local/nagios/bin/opsview_sync_ldap line 84.
Search options used:
base => OU=OU,OU=OU,DC=domain,DC=local
filter => (&(objectClass=group)(sAMAccountName=Opsview_Admin))
scope => sub
Could not find group Opsview_Admin in LDAP at /usr/local/nagios/bin/opsview_sync_ldap line 405.

I also tried running the opsview_sync_ldap specifing a username and password, which gave a similar output stating that it could not find the user.

 

Any advice on how to resolve this would be great

Johnnie