You are here

Latest 4.4 Update - LDAP Authentication stopped working

2 posts / 0 new
Last post
DolevFarhi
DolevFarhi's picture
Latest 4.4 Update - LDAP Authentication stopped working
hi We have upgraded to the latest version (4.4) and since then the LDAP authentication has stopped working. the error:   /usr/local/nagios/bin/opsview_sync_ldap -t Class::C3::Componentised::load_components(): Use of DBIx::Class::UTF8Columns is strongly discouraged. See documentation of DBIx::Class::UTF8Columns for more info Error on initial bind: 80090308: LdapErr: DSID-0C0903A9, comment: AcceptSecurityContext error, data 52e, v1db1 at /usr/local/nagios/bin/opsview_sync_ldap line 76.   the username i bind with has not changed, I even tried binding with my own user using the -u -p method, same error. please assist.      the yml file:   authentication:   realms:     ldap:       credential:         class: Password         password_field: password         password_type: self_check       store:         class: LDAP         ldap_server: ldapserver.us.company.com         ldap_server_options:           timeout: 30         binddn: binduser         bindpw: binduserpassword         start_tls: 0         user_basedn: "OU=Users,OU=ORGUNIT,DC=us,DC=company,DC=com"         user_filter: (sAMAccountName=%s)         user_scope: one         user_field: samaccountname         user_search_options:           deref: always         use_roles: 0         opsview_sync:           group_dir: /usr/local/nagios/etc/ldap           group_basedn: "OU=Users,OU=ORGUNIT,DC=us,DC=company,DC=com"           group_filter: (&(objectClass=group)(sAMAccountName=%s))           group_scope: one  

please assist

Thanks

smarsh
smarsh's picture
Re: Latest 4.4 Update - LDAP Authentication stopped working

Hey Dolev,

Best bet for this to be resolved is to raise it with support via http://support.opsview.com - i notice you havent created any tickets across any of your 3 subscriptions yet, so if you would like to drop me an email on sam.marsh@opsview.com i can talk you through what accounts you have set-up that are enabled to login to support etc.

Best,

Sam