You are here

Installing Opsview slave

7 posts / 0 new
Last post
Ronald_Veldhuizen
Ronald_Veldhuizen's picture
Installing Opsview slave

Ok, I'm installing a slave on Ubuntu 10.04.

Using this documentation : http://docs.opsview.com/doku.php?id=opsview3.0:slavesetup

When I reach the point ./check_reqs slave the following error is displayed:

sh: rrdtool: not found
Cannot parse versions at ./check_reqs line 370
        main::is_higher_version('', 1.0.33) called at ./check_reqs line 162

I'm a beginner in the (l)unix world and this is not understandable for me.

Any one can give me a hin how to solve this?

Ronald

 

smarsh
smarsh's picture
Re: Installing Opsview slave

Hi Ronald,

As explained on the other forum post - Slaves are not in Opsview Core I'm afraid. Would you like to speak to an Opsview sales representative around the commercial software, which does have slave servers?

Best,

Sam

Ronald_Veldhuizen
Ronald_Veldhuizen's picture
Re: Installing Opsview slave

I don't understand, I did install a slave, am I doing something wrong, or has there been a policy change? And I have opsview core installed as a master. And it runs other slaves.

Has there been a policy change that I missed?

Regards, Ronald

 

smarsh
smarsh's picture
Re: Installing Opsview slave

Ah - you mustnt have upgraded in the past ... 1-2 years, as in Opsview Core (introduced April 2012) there is no longer slave functionality in the 'free software'. Can you confirm what version you are running?

Unfortunately, if the above is true and you are running version 3.x, then this is very out of date now and such, all kinds of errors can be occuring at check_req's as packages may have been updated and change (apache, etc) since April '12. 

Ronald_Veldhuizen
Ronald_Veldhuizen's picture
Re: Installing Opsview slave

Hi, I'm running

Version: 20120424

Ronald

smarsh
smarsh's picture
Re: Installing Opsview slave

Hi Ronald,

Yep that looks like the last community version shipped - so April 2012 - so its fairly out of date.

Either way - the document you linked to in the original post is wrong - that one is "3.0" as it says in the URL -thats SUPER old. The one you need to look at is this: http://docs.opsview.com/doku.php?id=opsview-community:slavesetup

As mentioned above it says:

On the slave as the nagios user, source the profile then run check_reqs:

nagios@slave$ . ./profile nagios@slave$ ./check_reqs slave

Fix any dependency issues listed.

Have a look through the dependency issues and see how you get on.

Good luck,

Sam

Ronald_Veldhuizen
Ronald_Veldhuizen's picture
Re: Installing Opsview slave