You are here

Install Opsview Slave - PERL5LIB is not set

7 posts / 0 new
Last post
dvd_ds_85301
dvd_ds_85301's picture
Install Opsview Slave - PERL5LIB is not set

Hi guys!
 
I'm trying to install Opsview Slave on a Debian Squeeze.
When I do the verification of prerequisites, the system returns the following message:
 
"PERL5LIB is not set (the user profile has Been set-up ok?)"

Command line: ./check_reqs slave
 
All other requirements have been met.
Does anyone have any idea what is the procedure for setting the PERL5LIB?
 
The version of Squeeze is 2.6.32-5-amd64.
 
Any hint is welcome.
 
Thank you.

smarsh
smarsh's picture
What version of Opsview are

What version of Opsview are you trying to do this with?

dvd_ds_85301
dvd_ds_85301's picture
Hi Smarsh,I think it's 3.2.3

Hi Smarsh,

I think it's 3.2.3.

I'm not sure. How do I confirm?

Thanks.

smarsh
smarsh's picture
If you go to http://opsview

If you go to http://opsview/about where 'Opsview' is the IP of your system, that'll tell you.

dvd_ds_85301
dvd_ds_85301's picture
Thanks Smarsh.Version:

Thanks Smarsh.

Version: 20120424

 

Do you have any tips for this problem Perl?

smarsh
smarsh's picture
Ah. That explains it.

Ah. That explains it. 20120424 is an end-of-life deprecated version so its like any packages, pre-reqs etc are no longer available. Id recommend a supported version if you wish to use distributed monitoring. 

Please see here for more details: http://docs.opsview.com/doku.php?id=opsview-core:upgrading:upgradetocore

dvd_ds_85301
dvd_ds_85301's picture
Is there any workaround to

Is there any workaround to temporarily solve the problem immediately?

 

Thanks smarsh