You are here

How to disable active checks (3.20130304.0.11642)

3 posts / 0 new
Last post
shaun666
shaun666's picture
How to disable active checks (3.20130304.0.11642)

I've noticed that if I disable active checks on several hosts using "View Host Detail" -> "Disable checks of all services on this host" and then reload OPSview it starts all these checks again.

Is there a way to disable active checks in such a way that they remain disabled after a Reload?

A prompt answer would be much appreciated

Many thanks

Shaun

shaun666
shaun666's picture
Re: How to disable active checks (3.20130304.0.11642)

For the time being I've set the "Check Period" to 'Never' for each host.

However I really want my checks to remain disabled after a Reload so could some kind soul explain how I can configure this in opsview.conf?

TIA

Shaun

(And thanks for providing the Edit feature so I can correct my English)

awijntje
awijntje's picture
Re: How to disable active checks (3.20130304.0.11642)

he Shaun,

instead of disabling checks, have a look at putting the hosts into "downtime".

This will not stop checks executing but it will stop notifications for these services.

State information should be retained during a reload (it's an internal nagios thingy) but I'd have to go through the manual to see if disabling checks is retained aswell (as opposed to downtime for instance0.

hope this helps,

Alan