You are here

Dashboard Widgets not updating server name

3 posts / 0 new
Last post
ubiquitrips
ubiquitrips's picture
Dashboard Widgets not updating server name

Good Morning,

I am having an issue with the Dashboard widgets currently not updating the server names when you go to build a performance graph.  What happened is that the names of multiple servers were changed in a couple of ways.  Some from lower to uppercase letters, some from upper to lowercase letters, the others digits and characters were added.

In all cases, the names are not showing at all and / or not showing the updated name when attempting to select the server.  I have verified that perfdata is being tracked under each of the new names in the following location, /usr/local/nagios/var/rrd/.

One machine example that I have been working with is...

/usr/local/nagios/var/rrd/hqccl2n1

/usr/local/nagios/var/rrd/hqccl2n1a

/usr/local/nagios/var/rrd/HQCCL2N1

I have restarted httpd / opsview services.  I have restarted the server in its entirety as well.  These issues seem to survive the reboot.  The only thing I have not tried is removing the entire server folder under rrd.

I am running OpsView Pro 4.3.2.

Not sure what direction to try next, so I am open to options.

Thanks!

 

smarsh
smarsh's picture
Re: Dashboard Widgets not updating server name

Hello,

I can see that you are a paying subscriber to Opsview - could you contact Opsview Support via http://support.opsview.com and raise a ticket please? This will be the quickest course of action in terms of a resolution for your problem.

Best,

Sam

ubiquitrips
ubiquitrips's picture
Re: Dashboard Widgets not updating server name

I should have just finished out my process and it would have been solved.  The issue was that their were duplicate directories with different upper / lower settings and it was only seeing the uppercase version while it existed.  Removing that directory allowed it to see the lower case version and all is well.

Noted for the future!