You are here

Check_NRPE - Unknowns & Criticals - Dependency failures

3 posts / 0 new
Last post
waydms1059
waydms1059's picture
Check_NRPE - Unknowns & Criticals - Dependency failures

Hello everyone!

Currently receiving Unknowns for the check_nrpe service check after rebooting the system.
Running the enterprise virtual appliance provided by Opsview.

A sample check is as follows when viewing from testing...
check_nrpe -H $HOSTADDRESS$ -c check_disk -a '%DISK:1% -p %DISK%'

Also providing an image of the processes affected. Seems to be that all check_nrpe related services are either unknown or critical now.
Opsview Agent and Application processes are in a critical state and when I test the check, it returns connection refused by host. Cool, huh?

Any idea's why a simple reboot would give me such hassle? Also attempted another with no change.
Help much appreciated!

smarsh
smarsh's picture
Re: Check_NRPE - Unknowns & Criticals - Dependency failures

At a guess - opsview-agent service isnt set to start on boot (thus isnt running now).

waydms1059
waydms1059's picture
Re: Check_NRPE - Unknowns & Criticals - Dependency failures

Annnnnnd I don't feel ashamed of that misstep, haha!
Although I really could've checked deeper...seriously.

sudo su'd into the opsview user and started up the agent service, everything seemed to clear up. Will write up a small line to correct that.

Oddly enough that didn't seem to bother the system the first two reboots I did when playing with it the first day so maybe that's why I didn't think anything of it.

As always Sam, thank you!