You are here

Ubuntu 14.04 - Dependency errors

12 posts / 0 new
Last post
mcamcintyrem
mcamcintyrem's picture
Ubuntu 14.04 - Dependency errors

I've been following this online guide for installing OPSView on an Ubuntu server:
http://docs.opsview.com/doku.php?id=opsview-core:ubuntu-installation

I've been able to get all the way down to the section titled:  Installation.  I didn't have any errors at all.  Since Ubuntu 14.04 (Trusty Tahr) isn't listed in the available distributions for OPSview, I tried three different distributions available:  precise, squeeze and wheezy.  All three give me the same errors below.  Now when I try to install OPSView, using the specified command, sudo apt-get install opsview , I get several dependency errors and broken package errors.  

Reading package lists... Building dependency tree... Reading state information... Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: opsview : Depends: opsview-core (>= 3.20131016.0.14175) but it is not going to be installed Depends: opsview-web (>= 3.20131016.0.14175) but it is not going to be installed When I try to use Synaptic to install OPSview, I get an error saying that I need to fix broken packages.  When I try to do that, I get the following errors: E: Unable to correct problems, you have held broken packages. E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. E: Unable to correct dependencies E: Unable to correct problems, you have held broken packages. E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. E: Unable to correct dependencies E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. E: Unable to correct dependencies I'm hoping someone might have tried installing this on Ubuntu 14.04.  I don't know how to proceed and hope someone can give me some assistance.
mcamcintyrem
mcamcintyrem's picture
Re: Ubuntu 14.04 - Dependency errors

After figuring out a way to fix the broken packages for libgd2, I tried installing opsview again, using Synaptic, and I still get a long list of dependencies and it says that they are not installable:

opsview-perl: Depends: libperl5.14 (>=5.14.2) but it is not installable Depends: librrds-perl but it is not going to be installed Depends: libnet-snmp-perl but it is not going to be installed Depends: libsnmp-perl but it is not going to be installed Depends: libxml-perl but it is not going to be installed Depends: libnet-daemon-perl but it is not going to be installed Depends: libwww-perl but it is not going to be installed opsview-base: Depends: opsview-perl but it is not going to be installed Depends: ksh but it is not going to be installed Depends: mrtg but it is not going to be installed Depends: libgd2-noxpm but it is not installable or libgd2-xpm but it is not installable Depends: rrdtool but it is not going to be installed Depends: snmp but it is not going to be installed Depends: snmpd but it is not going to be installed Depends: libgd-tools but it is not going to be installed Depends: netpbm Depends: links but it is not going to be installed Depends: mailx Depends: libpq5 but it is not going to be installed or libpq4 but it is not installable 
smarsh
smarsh's picture
Re: Ubuntu 14.04 - Dependency errors

Opsview is not currently supported on Ubuntu 14.04, we are currently developing support for this new OS and testing. In the meantime, we would recommend an existing LTS of Ubuntu, i.e. Ubuntu 12.04.

jabulani
jabulani's picture
Re: Ubuntu 14.04 - Dependency errors
jamespublishing
jamespublishing's picture
Re: Ubuntu 14.04 - Dependency errors

What's the status and ETA on Trusty support given the fact that it is now in LTS? Lack of support is putting a real roadblock on my migration plans, and I'm sure other folks' as well.

smarsh
smarsh's picture
Re: Ubuntu 14.04 - Dependency errors

We are planning to get this out to our Enterprise/Pro customers in the summer, with Core potentially coming earlier if we decide to test this within the community first.

Best,

Sam

madleeen
madleeen's picture
Re: Ubuntu 14.04 - Dependency errors

Hello,

how does it look with the core support on 14.04 Trusty?

I am still getting "E: Package 'opsview' has no installation candidate" error.

Thanks,

Radka N.

trueability
trueability's picture
Update?

Can we can an update, or a link to the "Official 14.04" release/support documentation?  An official ETA would be appreciated.  Anyone using Opsview can't make any infrastructure upgrade plans until we know when you guys will support Ubuntu 14.04.  Atleast something we can track as far as progress, etc, towards an official release?

Thanks.

smarsh
smarsh's picture
Opsview Pro/Enterprise will

Opsview Pro/Enterprise will see the see introduction of support for Ubuntu 14.04, RHEL 7 and Centos 7 around the late October/Early December time period. 

Best,

Sam

stevenbrs
stevenbrs's picture
Hi there,

Hi there,

Any ETA already for opsview-core please ?

Thx
Steven
 

 

smarsh
smarsh's picture
Hi Steven,

Hi Steven,

At the moment there are no plans to release a new version of Core - if you require Ubuntu 14.04 / RHEL 7 / CentOS 7 support I would recommend purchasing a subscription.

Best,

Sam

Peter Vardenfell
Peter Vardenfell's picture
Even yet no support for Ubuntu 14.04?

Hi @all,

how about now with the Ubuntu 14.04 Support? The last post has been a while ago.

Greetings

Peter