You are here

Cisco switch doesn't report failed power supply via snmp

2 posts / 0 new
Last post
john.brokofsky@gd-ais.com
john.brokofsky@gd-ais.com's picture
Cisco switch doesn't report failed power supply via snmp

Hi,

I am a new user and am in the process of setting my system up.  I bought Opsview Pro 100 version 4.4.1  I am monitoring several Cisco WS-C4900M switches, among other things.  I thought I'd start workign with the switches first.  I enabled snmp on one switch with the following settings:

Switch> enable

Switch# configure terminal Switch(config)#snmp-server chassis-id Switchxx Switch(config)# snmp-server community public Switch(config)# snmp-server enable traps snmp Switch(config)# snmp-server host xxx.xxx.xxx.195 version 2c public Switch(config)#exit

 

I went into Opsview and added the switches using the Network-Cisco Host Template.  On one switch (the one I setup with snmp), I clicked on the SNMP tab and checked the "Enable SNMP" checkbox, selected version v2c, left the port at 161 and added the SNMP community.  I then clicked on the "Test SNMP connection", which was successful.

I noticed in monitoring that switch, I was seeing green for the CPU load average and the Memory status items.  The other switch had "unknown" for these items because snmp was not communicating properly (as expected - I did not set it up yet).

I thought I'd simulate a hardware failure to see if it was reported; I unplugged one power supply.  The switch front panel reflected the loss of power on one PS.  The error was never rippled back to Opsview; the Opsview status stayed green.

What am I doing wrong?

Regards,

John

smarsh
smarsh's picture
Re: Cisco switch doesn't report failed power supply via snmp

John,

You will need to either setup a trap in Opsview (New service check, SNMP Trap) then edit the rules.

 

Or, you will need a new service check (SNMP polling), SNMP walk your 4900M - add the OID for the PSU, then apply this new service check to your host. You may need to add the Cisco 4900M MIB to the Opsview system first.

Best,

Sam

PS: If this doesnt make sense, please contact Opsview Support who can walk you through this.