You are here

Problems getting graphing to work

5 posts / 0 new
Last post
Quang Le
quang_1's picture
Problems getting graphing to work

Hello,

I'm not seeing any graph icons in my opsview. Looking in the opsviewd.log i can see this error;

[2017/01/05 15:01:17] [import_perfdatarrd] [Opsview::Utils::PerfdatarrdImporter::catch {...} :69] [ERROR] Processing file=1483628476.039753: Timeseries ERROR: {"errors":["Updater http://127.0.0.1:1620/ failed: Service Unavailable"]} at /opt/opsview/perl/lib/perl5/Opsview/Timeseries/Client.pm line 176.

Everything is running when running opsview_watchdog summary

So far have tried;

- restarting opsview-timeseries processes plus everything else

- reinstalling opsview-timeseries-rdd, opsview-timeseries-lib, opsview-timeseries-enqueuer

Looking in the rdd dir, it was working at some point I think it stopped about the same time the system was updated to 5.2. 

Any ideas? 

Duncan Ferguson
dferguson's picture
Are you able to communicate

Are you able to communicate with the udpate daemon on port 1620?  Can you test with

telnet 127.0.0.1 1620

to prove it is listening?

Do you have any globally set proxies in your environment?  You can check with

env | grep -i proxy

If you have a provy set then this may prevent communications between the daemons

  Duncs

Quang Le
quang_1's picture
Aaah yes looks like my no

Aaah yes looks like my no_proxy env variable was misconfigured. 

wget http://127.0.0.1:1620/ 

made the problem obvious. Thanks for your help

 

 

 

Jeff Stockamp_2
jeff.stockamp_1's picture
This appears to be effecting

This appears to be effecting me as well ... i tried adding

no_proxy='127.0.0.1'

to my environment global environment variable in /etc/profile and I can connect to http://127.0.0.1:1620 using Curl and get a response from "Opsview Timeseries Enqueuer", but graphing is still not working and the 403 errors are still getting logged.

Did you have to do anything else to get this working?

Duncan Ferguson
dferguson's picture
Have you also restarted all

Have you also restarted all of the timeseries daemons to ensure they pick up the new environment settings?

As nagios

opsview_watchdog opsview-timeseries restart 
opsview_watchdog opsview-timeseriesenqueuer restart 
opsview_watchdog opsview-timeseriesrrdupdates restart 
opsview_watchdog opsview-timeseriesrrdupdates restart 
sleep 5
opsview_watchdog summary

  Duncs