You are here

Problem with webinject.pl output

2 posts / 0 new
Last post
andrejnoel
andrejnoel's picture
Problem with webinject.pl output

We recently migrated from GW to Opsview and have run into a problem with some checks that use webinject.

To summarize: We using the webinject.pl addon to log into a website as a generic user, then test that hyperlinks are available. This check worked in GW, and for the most part, all checks work in Opsview as well.  The issue is coming from certain checks that do not return any metics, they only return a Nagios status (0 for OK, 2 for Critical).  When run from a command line or using the 'Test Service' ability in the Opsview GUI, the status returns correctly as OK.  However, the check fails in Opsview with the following error message:

(No output on stdout) stderr: /bin/sh: -c: line 0: unexpected EOF while looking for matching ''
/bin/sh: -c: line 1: syntax error: unexpected end of file

I have tried modifying the output in several ways to see if that was the issue, I have also played with the input to see if that was the cause.  I so far have had no luck.  Given that the command works from CLI, I think that the issue is in the way that Opsview is interpreting the results.  Has anyone seen this before, or knows how to fix it?  

Note, that I did see this issue can sometimes occur with WMI checks and similar issues occuring when there are backslashes in other ypes of Windows checks, but that doesn't seem to be the case here.

 

smarsh
smarsh's picture
Re: Problem with webinject.pl output

Hi,

As an enterprise customer you should raise these issues as tickets via http://support.opsview.com as our professional support team can assist you quicker that way.

In the meantime, have a look at special characters in the URL - you may need to escape these using a backslash as Nagios/Opsview treats them differently than on the CLI/Test Service Check - i.e. one of your quotes or another character could be being treated differently - so Opsview thinks your missing a " - for example.

Best,

Sam