Sie sind hier

[Reports] jasperserver has issues when Opsview is configured to use HTTP over SSL

1 post / 0 new
mcurtis
Bild des Benutzers mcurtis
[Reports] jasperserver has issues when Opsview is configured to use HTTP over SSL

I have configured my Opsview installation to use the apache HTTP over SSL per http://docs.opsview.com/doku.php?id=opsview4.3:advancedapache#opsview_via_http_over_ssl

I have configured my reports module per: http://docs.opsview.com/doku.php?id=reporting-latest

I am able to access the reports module from Modules -> Reports and the single-sign-on successfully to the reports module.

For the purposes of this post the URL I am using is:

https://opsview-master.example.com/status/hostgroup?parentid=1

The reports module redirects me to:

https://opsview-master.example.com/jasperserver/flow.html?_flowId=search...

 

If I attempt to run a report or use any part of the interface I am redirected to the non SSL web page which is not enabled:

http://opsview-master.example.com/jasperserver/flow.html?_flowId=reportD...

I get the following error in my browser:

This webpage is not available Chromium's connection attempt to opsview-master.example.com was rejected. The website may be down, or your network may not be properly configured. Here are some suggestions:
  • Reload this webpage later.
  • Check your Internet connection. Restart any router, modem, or other network devices you may be using.
  • Add Chromium as a permitted program in your firewall's or antivirus software's settings. If it is already a permitted program, try deleting it from the list of permitted programs and adding it again.
  • If you use a proxy server, check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don't believe you should be using a proxy server, adjust your proxy settings: Go to the Chromium menu > Settings > Show advanced settings... > Change proxy settings... and make sure your configuration is set to "no proxy" or "direct."
Error 102 (net::ERR_CONNECTION_REFUSED): The server refused the connection.

 

How would I configure the reports module to always use HTTPS instead of HTTP?

When I manually edit the URL in the addressbar to be https:// I am able to access the correct page.